This Version of Internet Explorer Is Not Supported

We recommend you upgrade to a more modern browser.

Some options are Google Chrome and Firefox.

DISH Anywhere System Requirements

Versions listed below reflect the minimum version required for compatibility.

Computer Tablet Phone Console / TV / Other
Operating System
Android - 6 6 -
Android TV - - - 5
Fire OS - 5 - -
iOS (includes iPod Touch) - 9 9 9
Kindle - 5 - -
Mac OS X 10.9 - -
Windows 7 7 - -
Browser
Chrome (Mac) 55 - - -
Chrome (Windows) 55 55 - -
Edge (Windows) 37 37 - -
Firefox (Mac) 50 - - -
Firefox (Windows) 50 50 - -
Internet Explorer (Windows) 10 10 - -
Safari (Mac) 9 - - -
DISH Anywhere App
Amazon Fire TV/Fire Stick - 2.2.11 2.2.11 -
Android Phone/Tablet - 6.1.9 6.1.9 -
Android TV - - - 2.2.11
iPad, iPhone, iPod Touch - 7.15.6 7.15.6 -
Kindle - 6.1.8 6.1.8 -
DISHAnywhere.com
IE, Edge, Firefox, Chrome, Safari 18.3.1 - - -

  • There are no plans to integrate with Windows Phone or Blackberry at this time.
  • Browsers require Adobe Flash Player 11.0 or above to use Sling. Requires separate application to watch live TV.